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Graphing in Excel 
featuring Excel 20071 

 

A spreadsheet can be a powerful tool for analyzing and graphing data, but it works completely differently from 

the graphing calculator that you’re used to. If you’ve used a spreadsheet before, you may think of it as only 

being able to graph individual data points, but it’s actually pretty easy to get it to graph lots of ordinary 

functions, too. It is at its most powerful in graphing when those features are used together. This document will 

show you how to get a scatter plot of a set of data and how to graph a function with that data (a model of the 

data) to see how well it fits. 

The first thing we’ll need is some numbers. I’m going to use the set of times and drug concentration levels in a 

patient’s bloodstream given below. 

Time (h) 0.5 1 1.5 2 2.5 3 3.5 4 4.5 5 5.5 6 6.5 7 7.5 8 8.5 9 9.5 10 

Drug (µg) 9 8.3 7.8 7.2 6.7 6 5.3 5 4.6 4.4 4 3.7 3.2 2.8 2.5 2.5 2.1 1.9 1.7 1.5 

  

The first row will give the x-coordinate, and the second will give the corresponding y-coordinate. So it’s time to 

put the data into a spreadsheet. 

 

Open Excel. You should get a big blank page full of empty cells, and some tools along the 

top. Pick a cell somewhere in the top left area of the spreadsheet (which doesn’t have to 

be A1, if you’d like some space on the outside), and begin entering the information. It’s 

most natural to enter each row above as a column instead. Type the column heading, hit 

Enter, and you’ll be on the next row ready to type the first data value. When you’ve 

finished with the first column, start at the top again and enter the second one. Once 

you’re done, you should have something like you see at right. 

 

The “µ” symbol is a lowercase Greek “mu,” and it represents the metric prefix “micro" 

here. You can get it by using the Insert Symbol command, which in Excel 2007 is located 

in the Insert tab, way at the end. 

  

 … 

   

 

Once you’ve entered the data, it’s time to tell the program to make a graph for you. Excel will create a basic 

graph with very little prompting, and you can change whatever parameters (a/k/a “settings”) you’d like to. So 

select the data, including the headings, and go on to the next page.  

                                                           
1
 These instructions are more or less the same for any ordinary spreadsheet program, although the locations of the 

commands may be different. On the same site where you found this document, you should also find a second one featuring 

Excel 2003. It uses screenshots from that version of the program, but is designed to help you produce the same results. 
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With your data selected, go to the Insert tab. You should see something like this: 

 

As you can see, there’s a whole section devoted to charts. We’re going to choose a scatter plot, which is by far 

the most traditionally mathematical of the available types. If you’ll be graphing a function like you would on a 

calculator, the scatter plot is definitely where you want to start. 

 

When you click on the Scatter icon, you’ll get a drop-down menu with several versions of the 

scatter plot. The one we want is the ordinary one in the top left, just a bunch of discrete 

points. 

 

And here’s what I got. 

 

Not bad, right? But it’s not particularly well-labeled, certainly not sufficiently to communicate what the data 

means. There’s no indication what the values on the x-axis mean, for instance, and neither of the axes are 

labeled. 

 

When you click on the chart, you get three new tabs at the top for manipulating charts. 

 

I’m not sure I understand how the titles of these distinguish between the types of changes you can make in each 

tab, but you can generally find what you need fairly quickly. 

 

First the Design tab: 

 

Huge, right? I’ve made my window a little smaller and taken another screenshot that’s easier to read below. 
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As you might guess, choosing a different one of the dot colors in the Chart Styles section changes the colors. You 

can look through these, but remember that in communicating mathematics, clarity is vital. Don’t make your 

pictures so pretty that the style overwhelms the substance. The ones with the black backgrounds in particular 

may look good on screen (like in a PowerPoint), but won’t do that well in a printout. 

 

Next to the Layout tab. 

 

This is where you’ll be able to set the axis labels and such. 

 

On the left, you can select various parts of the chart from a pop-up menu. When you 

then click on Format Selection, you’ll be able to change colors and line styles and so 

on. The most useful things here for our purposes are those dealing with the axes. I’ll 

choose “Horizontal (Value) Axis” and then “Format Selection.” Here’s the dialog box I 

see. 

 

Sometimes you’ll want to adjust the maximum and/or 

minimum values and what the scale counts by. You do this 

by changing the appropriate radio button to Fixed and 

entering the value you want to use. I decided to change my 

maximum value to 10 and major unit to 1. Here’s how it 

looks now. 
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Moving right along, I’m happy with the y-axis 

scale, but I’d like to see vertical grid lines to match 

the horizontal ones. I won’t find that in this menu, 

so the next one I’ll use is the Gridlines one in the 

Axes section. What I need is to turn on Major 

Gridlines in Primary Vertical Gridlines. 

 

Here’s what I have now, but small. 

 

 

It’s looking better. What I would still like to do is remove the legend on the side, since there’s only one series, 

change the title to be a lot more descriptive, and put appropriate labels on both of the axes. Turning off the 

legend is easy, Select the Legend drop-down, and then None. 

 

To edit the title, just click on it once, and your cursor should become an I-beam (that’s what the text-selecting 

one is called) that you can use to select and edit the title just like any other 

text. To add labels to the axes, go to the Axis Labels menu, as seen at right. 

You get fewer choices for the horizontal label than the vertical one. I prefer 

rotated text for the vertical label myself, but feel free to see if you find 

something else more amenable to your tastes. Do remember that clarity is 

essential. 

 

When you choose to add a title in 

one of those places, you get a 

generic label on your graph, and you 

edit it the same way as you do the 

title, by clicking and selecting the 

text. After changing the title and 

adding descriptive axis labels, I have 

this result you see at the left. 
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If all you really need is a scatterplot of your data, you’re done. We never even examined what’s in the Format 

tab, but if you look, you’ll see that it’s just fine-tuning (and junking up, to some extent) what you already have. 

Up to this point, I’ve been taking screen shots rather than copying the actual graph to this document. Below is 

the real thing. The earlier pictures are limited to screen resolution, but the one below should print beautifully at 

any size. You just click somewhere in the graph’s bounding box, Copy, move to the word processing file, and 

Paste. You can resize it here if you want it to fill the space better. I’ve made mine the width of the text. (If you 

want to constrain the graph to the proportions you started with, hold down the Shift key as you drag one of the 

corner handles.) 

 

 

 

 

 

 

Pretty much anyone who works with spreadsheets at all can do something like this. It’s a really useful way to see 

trends over time. However, in mathematics, we generally want to model the pattern with some sort of formula. 

I have used a regression on my graphing calculator to come up with the function A(t) = 10.484 · (0.82942)
t
 for 

this one.
2
 I would like to graph that function along with these points to see how well it fits. 

 

As you’ve seen so far, spreadsheets deal with discrete data points, and they don’t really do curves that aren’t 

just connecting those dots. However, that’s precisely what a graphing calculator does. In this case, we have to 

tell the spreadsheet what x-values to use, have it find the corresponding y-values, and connect those points with 

a nice smooth curve. 

                                                           
2
 If you need to know how to find such a function with a regression, there’s another tutorial on this site for just that 

purpose. Actually, there are two: one for the TI-84/83 series calculator, and another for the TI-89. 
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I would like my function to graph on the interval [0, 10], and I want plenty of points to connect to ensure that I 

get a good shape. I’m going to make a table counting from 0 to 10 by 0.1. Here’s how. On your spreadsheet, pick 

a new place to enter data, perhaps below the original data, perhaps beside the chart, whatever works for you. It 

is helpful to be able to see the chart with at least the beginning of the data. Enter column headings: t and A(t). 

Then in the cell underneath t, type the first value, 0. 

 

Select the cell containing 0, and then go to the Fill menu choice on the 

far right of the Home tab. Choose “Series…”. This is a brilliant little tool 

that lets you count by whatever you’d like for as long as you want. I’ve 

decided to count by 0.1 until I get to 10. You can see how I’ve entered 

that. Note that I told the program that I want the series in columns. If I 

had left it as rows, it would have gone to the right instead of down. Click 

OK, and you have a really nice list of values of t to use in finding the 

values of A(t) that we’d like to graph. 

 

To get Excel to calculate those values, you’ll enter the function as an Excel formula in the cell adjacent to 0, and 

then Fill Down to get it in the rest of the cells. 

 

The formula starts with your typing an = sign. That’s how Excel knows it’s supposed 

to calculate something rather than just displaying it. The syntax is just like that for a 

calculator, as you can see. The one peculiarity is P5. Why P5 instead of t? Because 

that’s where the value I want plugged in is located. See? 

 

I didn’t actually type P5. I got it by clicking on the cell I wanted when I got to that 

point in the formula. After I typed Enter, I got the value you see to the right. To get 

the rest of the A(t) values, select that first cell (Q5 in my case), and drag a selection down all the way to the 

bottom of the table of values, so that the last selected cell is next to t = 10. Now go back to the Fill menu again, 

and this time just choose Down. Excel will copy the formula into each of those cells, but will update the cell 

that’s referred to each time. In the second row, it will say P6, then P7, and so on, so that each value in the right 

column is calculated from the one immediately to its left. It’s a big table like your calculator would make. 

Before Fill Down:  After Fill Down:  

 

 

This big list of points is what I’m going to graph with my original 

curve. Getting them on there in the first place requires adding data 

to the chart we already created. Then it takes a couple of 

adjustments to make the graph look like something other than a big 

mass of dots. 

 

Click on the chart again, and this time choose 

Select Data in the Design tab. We’ll be adding 

another series, so in the resulting dialog box, 

click Add. 
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While it’s possible to type a whole bunch of stuff into the Edit 

Series box, you can also select things by dragging, and that’s 

generally simpler. The way you do this is to put your cursor in the 

appropriate box and click the little icon with the tiny arrow next 

to the right of the text box and to the left of where it says “Select 

Range”:  

 

 

 

When you do that, the box shrinks up to something like the one 

seen here. Don’t panic, the large one will come back. Use your 

cursor to select the cells you need. For Series name, I selected the 

cell that said A(t). Then I clicked that little tiny arrow button on 

the right of the reduced box, and got right back to the previous 

Edit Series view. I did the same thing for Series X values, this 

time dragging all the way from 0 to 10 down my table of data. 

And when you get ready to select the Series Y-values, delete the 

“={1}” that you see here if it shows up for you. After all of that 

selecting, you should have something like this: 

 

Click OK, then OK again, and watch the HUGE dots appear. 

 

There are two reasons why this is not so great. The 

first, and most obvious, is that it obscures almost all 

of the original data points. The second, and at least 

as important is that what I’d like to see is the function 

A(t), not a big collection of dots of any size. 

 

We’re going to change the way the second series of 

points is displayed, so that the dots are not shown, 

but a smooth curve connecting them is. 

 

Click on the chart, and go to the Chart Layout tab again. On the very far left, from the pop-up menu, select the 

series we’re going to be editing, ‘Series” A(t)”.’ (At first, I didn’t see that choice, only the Drugs one, but I let up 

on the button and tried again and there it was. I’m not sure what that’s about —maybe I was thinking too fast 

for the software?) Then click the Format Selection button immediately below the pop-up menu. This is where 

we’ll do the fixing. 

 

First is to remove the big diamonds. Click Marker Options, and choose none. At this point, your graph will look 

eerily unpopulated. It’s okay. Next go to Line Color and choose Automatic, or whatever other readable color 

you’d like. Now make it a curve rather than a bunch of little segments by choosing Smoothed line from the Line 
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Style pane. If you don’t like the weight of the line, you 

can change that here, too. Click Close to get out of there. 

You’re almost done. 

 

 The very last thing that this graph needs is a legend. You 

may be asking why, since I specifically removed the 

legend when I made the scatter plot at the very 

beginning. The answer is that now there are two things 

graphed, and the reader needs to know which is which 

without having to look it up in the text or compare it to 

an earlier graph. 

 

To add the legend, once again select the chart, and from the Chart Layout tab, click Legend. You get several 

choices of where to put it, and you can choose what seems most legible to you. I don’t always choose the same 

thing. And here’s my finished graph, including both the scatter plot and the regression line. 

 

I fancied mine up a little bit with a white background and an outline. You don’t have to. That’s it, eight pages 

later. I did this rather quickly, so let me know if you find any typos or if I appear to have left out any steps. 
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